Troubleshooting simple printing issues
You can find answer to the most common printing issues in this article.
Switch between local printers
You can learn from this article how to switch between local printers.
While connected to your host computer, you can switch between local printers. Note that this feature is only available for Windows users connecting to a Windows host computer.
- From the Viewer, select File in the top toolbar and Select GoToMyPC Printer.
- Select the desired printer in the drop-down list.
- Return to the file you wish to print and print with GoToMyPC Printer.
- Your file will be directed to the printer you selected.
Finding the printer's driver or manufacturer in the Printer Setup Wizard
Windows does not have all printer drivers pre-loaded in its database.
You must do the following:
- Download and install the printer driver yourself from the manufacturer's website,
- Select the Have Disk option in the Printer Setup Wizard when prompted for the manufacturer and printer.
What to do if you can't see your printer after downloading the drivers for it
What to do if your GoToMyPC printer is missing
The GoToMyPC printer should be available whenever you are remotely connected to your host computer. It disappears when your session is over.
If the GoToMyPC printer does not appear in your list of printers when you are connected to your host computer, you may need to reinstall the GoToMyPC software.
Why the print icon in the toolbar might not work in your client or host computer
The GoToMyPC Printer may not be selected as the default printer while in session. Change the Printing Preferences so the GoToMyPC Printer is automatically set as the in-session default printer.
If you do not want the GoToMyPC Printer to be the default while in session, you will need to select the GoToMyPC Printer each time you print from your application's print window.
Resolve a "The specified location does not contain information about your hardware." error when trying to add the .inf setup driver
- Symptom
- When installing the printer drivers to a host computer, I get the following error message: The specified location does not contain information about your hardware.
- Cause
- The error message appears when the Add Printer Wizard fails to install the selected .inf setup file, usually due to an incorrect driver.
- Resolution
-
Verify the driver from the manufacturer's website. Some print drivers include several .inf files. If the first fails, direct the Add Printer Wizard to a different
.inf file.
Important: Printer drivers are either 32-bit or 64-bit. You must use the same driver version as your computer's Windows version.
Document is not printing from the GoToMyPC printer
Try and print a job on your client computer before attempting to print remotely through GoToMyPC. If printing is not working locally on your client computer, GoToMyPC remote printing will not work.
The GoToMyPC Printer uses a universal print driver that works with most printers. Your printer, however, may require you to install a matching print driver on your host computer in order to process print jobs sent by a remote printer. Please see our article on manually enabling a printer for assistance.
Troubleshooting incorrect color or alignment on a print job
For precision printing, manually enable the client computer's printer. Please see the section on manually enabling a printer for details.
If you still experience issues, call us by selecting Contact Support.